Forums

Publishing of images fails

  1. When travelling I am offline most of the time, so I have to edit my posts offline, add images and save it locally, by trying to publish. As soon as I am online I then go to the post and publish the post which works, but images are not uploaded. This requires me to edit each post again which is a nightmare.
    Any help aprecciated
    WP is 5.1.2 Android is 5.0.2

  2. Hi wehpeh,

    Could you explain a little more about what's happening - do you mean that you are able to successfully add media into your post while it's offline, however when you are next online and upload your post it doesn't work? Does this happen every time, or is it just some times that you do this?

    Do you receive any errors during this process? If so, what do they say?

    I tried testing the steps you've outlined using a WordPress 5.1.2 website with the Android App, and I was unable to replicate the problem. When I create a post offline and added media, later on when I connected back to the WiFi connection I was able to then upload the post successfully along with the media I had added to it.

    We'd be happy to take a closer look into what might be happening. Please go to "Me > Help & Support" in the app and tap on "Contact us" so we can investigate it from there. Please make sure to include the address of your website in your message so that we can take a look and troubleshoot this problem.

  3. Hi Anna, txs for taking care of the issue.
    Here is what happens , more detailed
    Being OffLine I open the app, go to post and add a new post. I give it a title, type some text and add one or more pictures. These pictures become "red overlayed" immediately. Then I press "publish", which ends with the message "device offline saved locally".

    Now I go on-line, open the app, go to posts where the unpublished post has a red flag and alert message "unable to upload this post media", Then I click "submit". Post is published w/o error message.
    If I go to the WP page on the server, page is there but w/o images. Just broken links are shown instead.

    If I edit the post in the app, the images are shown with the red overlay again, plus an icon suggesting to reload. If I click the item the image becomes clear, red overlay is gone.
    If I click "update", pictures are updated on the server.

    I will follow your instruction and contact you through the app
    txs

  4. Hi,
    I've the same problem here. If I want to put a photo into an new blog entry, while I'm OFFLINE, the android app immediately try to push it to the server, which obviously will fail with the error message: "Failed to insert media. Please tap to retry."
    But as I'm offline, there is no way to push the media immediately to the server, while I'm editing a blog entry.

    So how can this issue be resolved? I also couldn't find any settings I should have changed for that reason.

    I can recall that back in 2014 with WP 4, and the according android app, it was already working out of the box: Writing a blog entry completely offline, including all media and captions, and finally push it to the server, once there's WiFi available. So, why is that feature no longer working out of the box 5 years later?

    Thx

  5. Hi Boroli,
    I added the classic editor plugin to my WP site and use "image" as post type . Can't remember where I did set the post type, but thats is what my notes are telling me ;o) )
    Since then it works

  6. Just found out....
    PlugIns-ClassicEditor-Settings-Default Post Format "Image"

  7. Thx for the quick response. I've a wordpress.com blog and can't install additional plugins.

    I tried to change in Settings -> Writing -> Default Post Format (you can access this option also from within the android app, in settings of each post)

    From Standard to Image, but without any success. The problem still remains.

  8. Hi I have got same issue with publishing pictures once i am online. Were you able to find any solution?

Leave a Reply

You must log in to post.


About this Topic