Forums

http status code: 412 was returned

  1. I keep getting this so I have not been able to log in?

    I have the newest android upgrade, I also have the newest wordpress both on my phone and on the server. I am self hosting the blog.

    Please help this would be great to be able to post from my phone.

    Thanks

  2. Hello,
    It appears that your server isn't configured properly. If you visit http://www.clamgasadventure.com/xmlrpc.php, you'll see the error printed on the page.

    The precondition on the request for the URL /clamgasadventure//xmlrpc.php evaluated to false

    Those two '//' could indicate that there's something wrong with the file paths.

  3. So how would I configure my server correctly?

    I get the same error at http://hemorrdroids.net

    Thanks.

  4. Hi mrroundhill, i looked at the post for the iphone and it was helpful. I posted a reply and felt it would be valid here too since I'm using a motorola droid not an iphone.

    Hi i was redirected to this forum from the following droid forum:

    http://android.forums.wordpress.org/topic/http-status-code-412-was-returned

    I'm having the same issues as billciairi. Mine are on the motorola droid using wp 1.2. And here's what's werid. I too use ICDSoft as my host. Currently, i have one blog with a working xmlrpc.php and two new blogs that don't work:

    working one:
    http://www.madtm.com/oleo/xmlrpc.php

    non-working ones:
    http://www.madtm.com/xmlrpc.php
    http://www.madtm.com/earlid/xmlrpc.php

    How is that possible? I've replaced the xmlrpc.php file on the two non-working blogs with the working file and still nothing.

    should i just add that piece of code to my .htaccess and call it a day?

    <Files xmlrpc.php>
    SecFilterInheritance Off
    </Files>

    thanks all for your thoughts.

  5. discoverybasededucation
    Member
    Mar 19, 2011, 4:33 PM

    ERROR: HTTP status code 412 was returned. Precondition Failed

    Hello,
    Any suggestion would be greatly appreciated.

    I too use icdsoft, with a self hosted, using WP3.1, Android 1.3.9

    http://discover.zondi.com - blog

    .htaccess set to 664
    xmlrpc.php - all set to true

    Do I need to look at renaming my xmlrpc.php file?

    mysql db set to enable remote (necessary for web based version to function)

  6. discoverybasededucation
    Member
    Mar 19, 2011, 4:35 PM

    Note: I have tried entering the URL into the app as

    http://discover.zondi.com

    http://discover.zondi.com/index.php

    http://zondi.com/home/zondi/www/discover/......

    Same error on all attempts - the only thing I haven't tried is renaming the xmlrpc.php file...

  7. discoverybasededucation
    Member
    Mar 19, 2011, 4:38 PM

    Update: Tried renaming xmlrpc.php to xmlrpc_post.php and entering direct url into app - no change, same error

  8. I get the same error when directly visiting http://discover.zondi.com/xmlrpc.php

    Is the file at that location? Anything in your .htaccess that might be blocking access?

  9. discoverybasededucation
    Member
    Mar 19, 2011, 11:27 PM

    Guessing that is related to having tried the renaming in the last post, and not changing it back... I'll add the same file named xmlrph.php directly

    .htaccess content as follows
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  10. discoverybasededucation
    Member
    Mar 19, 2011, 11:28 PM

    Try both

    http://discover.zondi.com/xmlrpc_post.php = XML-RPC server accepts POST requests only.
    http://discover.zondi.com/xmlrpc.php = Precondition Failed -The precondition on the request for the URL /xmlrpc.php evaluated to false.

    I have tried removing the code from the .htacess file completely, and replacing with
    <Files xmlrpc.php>
    SecFilterInheritance Off
    </Files>

    Upon doing so, the same error is returned

  11. discoverybasededucation
    Member
    Mar 19, 2011, 11:31 PM

    And when trying the htaccess mod to ONLY (xmlrpc.php is the one I changed - haven't tried the change on the rename yet)
    <Files xmlrpc.php>
    SecFilterInheritance Off
    </Files>

    Android app returns: XMLRPC Fault: CML-RPC services are disabled on this site. An admin user an enable - error 405

  12. discoverybasededucation
    Member
    Mar 19, 2011, 11:32 PM

    Ok, with the .htaccess file changed to shot only
    <Files xmlrpc.php>
    SecFilterInheritance Off
    </Files>

    - while the xmlrpc.php (named) file returns the above error (405), the renamed xmlrpc_post.php (named) file returns the original 412, precondition failed error

    Not sure what else to try - I think I have attempted all known fixes, in all possible combinations/directions. I must be missing something.

  13. discoverybasededucation
    Member
    Mar 19, 2011, 11:35 PM

    It's tellin me an dadmin user can enable them at {blog}/wp-admin/options-writing.php

    SOOOO now I will review this file.

  14. discoverybasededucation
    Member
    Mar 19, 2011, 11:38 PM

    <tr valign="top">
    <th scope="row"><?php _e('XML-RPC') ?></th>
    <td><fieldset><legend class="screen-reader-text"><span><?php _e('XML-RPC') ?></span></legend>
    <label for="enable_xmlrpc">
    <input name="enable_xmlrpc" type="checkbox" id="enable_xmlrpc" value="1" <?php checked('1', get_option('enable_xmlrpc')); ?> />
    <?php _e('Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols.') ?></label>
    </fieldset></td>
    </tr>
    <?php do_settings_fields('writing', 'remote_publishing'); ?>

    hummmmmm

  15. discoverybasededucation
    Member
    Mar 19, 2011, 11:44 PM

    Solved.

    Jeez..............

    So, editing the files directly and setting all to true was apparently not sufficient.
    From within the blog settings control panel, writing - XML-RPC was not checked as enabled.
    Clearly the blog control panel settings interface modifies more code than I did manually in the lines in xmlrpc.php

    In summary: If you're using an android, latest versions of everything, and whether my host (ICDSOFT) has anything to do with it or not, before you mess with anything check in your "Settings -> Writing" control panel and make sure the XML-RPC is enabled fully.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.