How to Fix Wordpress App stop working after update 5.2.1?

  1. I use wordpress app in android to write post and share them using the XML-RPC technology, nevertheless I have updated my website wp to 5.2.1 and all the sudden the app now is showing this error GENERIC ERROR !!!

    I uninstall the app and reinstall it, now I can't even login to my website, saying this message:

    Couldn't connect. required XML-RPC methods are missing on the server

    how can I fix this without breaking my website!!

    Update: I reinstalled wordpress 5.2.1 and now the app login to my website but it only show two previous posts and I cant upload new posts.. freezing at uploading & fetching since hours. when I try to upload a new post it said the same error GENERIC ERROR .. failed to upload :/

    PS: I also updated php from 5.2 to 7.2 in Cpanel

  2. Hi ClipAxis,

    It sounds like the problem here is with XML-RPC, This is a service that the WordPress app requires on your server. When it's not functioning correctly you will usually either see errors such as the 'required XML-RPC methods are missing on the server' error you saw, or alternatively you may be able to connect but without the ability to upload or sync to the site.

    XML-RPC issues can also happen if there is a plugin/theme that conflicts with it. To check whether a plugin is causing the conflict with the app, try deactivating all the plugins on your self-hosted site to see whether that fixes the issue.

    If you'd like assistance in troubleshooting this, we'd be happy to take a look. Please go to "Me > Help & Support" in the app and tap on "Contact us" so we can investigate it from there. Please make sure to include the address of your website in your message so that we can take a look and troubleshoot this problem.

  3. Hello Ms. Anna,

    I would love your assistance, and I'm going to contact your support asap. The thing is I really have to fix that issue because I can't be on pc all day to share my posts.

    Nevertheless I will try the disable all the plugins as you have requested and see what would happen, although I don't think that a plugin is making an issue, because all I use is yoast, wp security ( I already checked that XML-RPC is not blocked by it in firewall) and official amp plugin, google analytics and that all. While using a premium theme called NEWSPAPER.

    So I believe the issue is when I updated to WP 5.2.1 or when I updated php from 5.2 to 7.2. Because a day before everything was working just fine.

  4. Have you tried downgrading PHP back to 5.2? I'm having same problem I will try downgrading the PHP ater today.

  5. Hi there meguinness!

    I wouldn't recommend downgrading your PHP version back to 5.2 as this could create a number of other issues and the latest version of WordPress requires at least PHP version 7.3 +

    If you're having trouble connecting your site to the app, please reach out to us with your site URL so we can help you with this. There could be many reasons why this is happening and there should be no need for you to downgrade your PHP version.

    You can find us in the app under Me > Help & Support > Contact Us.

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.