error in uploading images

  1. while I uploaded images without any problems in wp2go, the new application gives me an upload error, always, when uploading an image.
    which is bad, since I have a photoblog.
    it happens uploading pictures that I took with the phone camera.
    I should add that my post are empty (with only a "space" in the text field).

    what could I do to trace down the cause of the error?


  2. what's the upload error that you get from the app?

  3. "Post edited successully, but an error was encountered when uploading images"

    (now it comes to my mind that I should check directory permissions for the uploads folder, maybe wordpress isn't able to create the 2010 folder. I'll let you know if that's the issue here)

  4. I manually created wp-content/uploads/2010/02 and 777ed it, but I get the same error.
    anyway it seems that wordpress isn't able to create the uploads folder at all

  5. solved: it didn't have anything to do with wordpress for android.
    the upload path got messed up, I had to remove a slash before the upload path in miscellaneus options.
    thanks for your help.

  6. great, glad it's working now!

  7. I am having similar problems.

    I get "Post edited successully, but an error was encountered when uploading images"

    When I go to the ftp site the images are all there and I can get them into the post via editing post on the wp-admin.

    They never show up in the post when posting from WP for Android. Although the rest of the post goes up.


    Now there is some goofy things going on with respect to redirecting to just if that is helpful...

  8. Image problems reported are against Beta Version 1.1

  9. @lincolnsmithy - That error usually happens because of a configuration issue or folder permissions - the redirect you are doing could be confusing it. Also, your site seems to be taking quite a while to load, does it take a long time to upload the images?

    It also couldn't hurt to upgrade your WordPress install, looks like you're on 2.7 :P

  10. Yes, site does take a bit to load - probably my hosting provider.

    Images go up pretty quickly - like I said, they all make to to the system but the error occurs anyway. I was able to use the uploaded images from the wp-admin as well. So it is pretty close to working. I will mess with upgrade and redirect in the meantime.


  11. Redirect stuff is cleared up - it was the way I had it set in wp. This did not fix the image problem though.

    Image problem only occurs in Beta not in 1.0.1 - So I believe the problem is in the Beta version and not a setting issue on the blog or hosting site.

  12. In the beta version, can you turn off the full size image option and try again?

  13. Hello,
    on my G1 I still have problem with upload image from my phone. I use 1.1.2 version, and if I try to upload post with image, post will be upload without image.
    Error I get: "Post edited successully, but an error was encountered when uploading images" like alekone above.
    The attempt to solve with delete slash not help to me...
    What should I do to upload images?

  14. @brazajar - do the images still end up in your media library? Are you uploading the full size image?

  15. I'm having the same problem. I'm using the LG Eve... I get that same error message as those guys. I created a 2010 folder in the uploads folder but it still doesn't work. Are the images I'm uploading too large or....

  16. I discovered that the problem was the same as the guy above. Wrong file path for files to be uploaded

  17. Sorry for my delay...

    No, pictures are not upload in my media library .. only I have is folder 2010.
    And yes ... I tried both way - with full size link, only "thumbs" ... still have that error.

  18. Today I got a new version via market - 1.1.3 ... but the problem I post above is still here ...
    No upload image, in image folder new folder called 2010 - and no image there...

  19. Can anyone be more specific on the issue with the upload directory path?

    I have the same issue noted in other posts - "Post edited successfully, but an error was encountered when uploading images"

    Wordpress 2.9.2
    HTC Eris w/ Wordpress 1.1.3 app

    I have the default directory for uploads configured: wp-content/uploads

    upload works in a web browser post (from desktop), folder 2010/04/ was created and i set the perms to 777 just to be sure...

    I'm stuck - would love to use the app, but it's costing me more time than I hoped.

    Perhaps I'm missing a slash somewhere, but i need some help with the details. Thanks!

  20. Originally after I installed the app I had the same issues as all above.

    Verified what alekone did to fix issue.

    Normally wordpress defaults to wp-content/uploads, I left mine as the default. Well in my case the uploads folder was not created. I created the folder and chmod 777 the folder and tried to upload from the phone again and it worked without issue.

    The phone creates the YYYY/MM folder.

    Currently running app version v1.1.5

  21. When I started using the Wordpress app for android I could upload images in a blog with the app, after I started exploring the Wordpress dashboard and made some changes I suddenly couldn't. It must have been in the changes I made.
    In the map settings/other options (i don't know if thats correct in english, I translated from dutch) I made a change by checking store uploads in folders by month/year. I unchecked the box and now I can upload from the app again. Maybe this helps for some of you...

  22. Can someone please explain this in laymans terms? I dont follow the 777 suggestion; I am having the same issues with my Desire. I am using WP v1.2

  23. Originally I was having the same problem - error uploading image. I sent an email using the Marketplace and got a response back within minutes - on a Sunday! Unfortunately the message indicated the presence of this forum topic but no link and I forgot to follow up until today.

    Turns out my site didn't have the wp-content/upload folder present, so I created it and set the permissions to 777 using my ftp client (btw the '777' thing for Drebo means the folder needs to have full permissions set for all users basically).

    Now I get Force Close when uploading the post, which happens _after_ the media upload. The media files are all in the (newly-created) wp-content/upload/2010/06 folder, including 2 different-sized thumbnails.

    I'm using WordPress for Android v1.2.1 on a Motorola Droid running 2.1update 1, posting to a 2.9.2 WordPress self-hosted blog @

    I've even tried setting the specific path to the upload folder in the misc settings, same issue, so I reset it to blank.

    I've tested uploading media through the standard web interface, have no problems.

    Any assistance appreciated; I used the Report option when the app crashed a couple times, maybe that'll help.

  24. @TimDraper - maybe try uninstalling/reinstalling the app if you haven't already. Are you uploading full size media? It could be an out of memory error if I'm seeing your error report correctly (It's hard to tell who's who). A device reboot might help with the memory error.

    Let me know how it goes.

  25. DId a reboot, used TaskPanel to shut down all background programs. Was showing ~92MB available memory when I launched WP.

    Created new post with the same pic that's been used to date and MAN the Gallery took forever to load up. Shut down Gallery again before uploading (again via TaskPanel) and same F/C happens.

    Just for S&G I also uploaded the original file via ftp, and it looks like maybe the WP app is creating 3 snapshot views? The original image is 2k by 3k pixels, 3.8mb; the largest file in the uploads folder is 500x667px, 81kb.

    The files uploaded by WP were all named wpid-filename-150x150.jpg or -224x300.jpg or just ;wpid-filename.jpg

    The original file was roughly 2kpx x 3kpx; it had been cropped already from a 12mp camera shot. I converted the file myself to a 684x912px file and upload worked fine.

    I tried uploading the original 2x3kpx image and the same problem happened (Force Close after creating/uploading 3 different snapshot images). TaskPanel showed 59mb free when I opened it after the F/C.

    On the other other hand, posting a picture taken by the Droid's 5mp camera worked fine @ 2592x1936px, with five snapshots created (two each named 112x150, 224x300 and the 'full size' 373x499 snapshot, looks like 1 of each snapshot is rotated 90degrees?)

    I guess for now I'll have to use my laptop to post any larger pics - I don't use the Droid camera because it just doesn't focus well for me, while I have a nice, small, 12mp point'n'shoot that does. It looks like for some reason there's a maximum file size or resolution before the WP app goes 'blooey', could be running out of memory I guess but if it is, it's being nice and releasing what it used when it crashes ;) Thank you good coders!

    I also checked, and I have all the 'max media size' settings on my blog set to 4kx4k just to be sure.

  26. Ok, so you're uploading from the gallery, but the pictures were side loaded from a 12MP camera? That's probably it :) We rotate and create a thumbnail to display in the app, and I bet it's crashing when trying to load that large file into memory to create the cutdown.

    I've got a droid, will try and reproduce and get a fix out for ya.

  27. Yep, having succeeded finally I did notice that the failure is before creating the rotated snapshots.

  28. I have same basic issue, no FC though. I'm trying to load a 1.3mp HD video that's about 30 seconds long. Was redirected here from xmlparse thread. Tried the 777 and wp-content/uploads. Verified load permissions. Still not working. Any tips?

  29. I am having the same issue; i am using wordpress 1.3.5 on the android; when creating/editing a post i am not able to see the picture in the post; i am receiving the error message "Post edited successully, but an error was encountered when uploading images"

    my site is and is using the current version of wordpress.

    the picture is being uploaded to the server and is visible when i look at content/uploads folder.
    the folder does have full permission of the 777

    though the image is not visible in the post.

    any ideas?

  30. I was able to figure out what the problem is; there is an option in the blog settings that says 'upload and link to full image'; i had this box checked and this is why the upload of the picture was failing.

    I am able to successfully upload a new post with pictures now as long as that box is unchecked.

Topic Closed

This topic has been closed to new replies.

About this Topic