Forums

App slow on self-hosted site

  1. The WordPress app seems to communicate very slowly with my self-hosted site (currently running 5.5, but the issue affected earlier versions).

    This includes loading lists of posts, publishing posts and updating them.

    For example, when I update a post, the "rising arrow" appears in my status bar for minutes. However, when I admin the site using a web browser, the post update appears to be finished long before the app notifies me that it's done.

    Android version: 7.1.1
    Connection speed: 4g
    WP app version: 15.4

  2. Hi there!

    Thanks for reaching out about this.

    It sounds like what you're saying here is that when you check your site in a web browser, the posts you updated in the app are showing as fully updated but the app is still showing that it's loading. Does that sound right?

    There's a number of factors that can affect this. For example, the internet speed you are sending the requests from, the distance you are from your hosts servers, the time it takes for your server to respond to the requests sent from the app and the time it takes for the app to receive the response back, and also the speed of the device you're using to verify this.

    It can be difficult to narrow down things like this to a specific issue as it's sometimes a combination of things, but if you notice that there are significant delays that are interrupting your workflow it would be good to try and narrow it down to what is causing the most delays.

    First, you could try from a different network connection. For example if you're on 4G, try switching to WiFi to see if this makes any difference.

    The other thing you can do is confirm that your server is well configured and you don't have anything that may be blocking the performance of your site. Things like plugins that you don't really need. You can install a plugin like https://wordpress.org/plugins/query-monitor/ to determine poorly performing plugins, themes, or functions you may be able to disable.

    You can also test different sites if possible to compare the differences.

    The last thing I would suggest is to try from a different device if that's an option. Then you can rule out any issues specific to your device. I'd suggest something with a more recent version of Android if possible.

    If you're still having significant delays, let us know your site address or try reaching out to your host to see if there is anything they can suggest.

    Thank you!

Leave a Reply

You must log in to post.


About this Topic

Tags

No tags yet.